Allgemeines

Serverinstaller (c) Harald Antkowiak itservice@lanmagic.de

Allgemeines

Der Serverinstaller bietet die Möglichkeit, alle notwendigen Grundeinstellungen auf einem Server oder auch Workstation zu setzen.
Dazu gehören Desktop- und Startmenüansicht, Explorereinstellungen, verschiedene Tools usw.
Server oder PC wird automatisch erkannt und empfohlene Grundeinstellungen gesetzt.
Daneben werden BRZ-spezifische Einstellungen gesetzt und Tools installiert.
Alle Aktionen werden in einer Logdatei dokumentiert.
Die Einstellungen können in einer INI-Datei gespeichert werden. Diese können nach Bedarf wieder eingelesen werden. Passwörter werden verschlüsselt abgelegt.
Die Updatefunktion ermöglicht automatische Updates über das Internet beim Vorliegen neuerer Versionen.

Das Programm muß nach 5 Tagen Benutzung lizensiert werden. Hinweise findenSie unter Lizensierung .

Das Paket Serverinstaller besteht minimal aus 2 Dateien:

servinst.exe und servinstall.zip

Dazu kommt je nach Notwendigkeit die servinstall.ini, die die Einstellungen speichert..
 Eine Nutzung des reinen Programms (ohne .ZIP-Datei) ist NICHT möglich.

Screenshot


Einstellungen

Explorer-Ordner-Einstellungen - setzt Einstellungen für Explorer/Startmenü (siehe dort)

Zeitabgleich - erzeugt eine Datei, die den Internetzeitabgleich durchführt

Neustart-Einstellungen - eine Datei wird erzeugt, die den Neustart des Servers durchführt

Systemeinstellungen
setzt grundlegende Einstellungen des Systems (siehe dort)

Defragmentierung - erzeugt eine Datei, die die automatische Defragmentierung der Laufwerke durchführt

Sicherung der Registry - erzeugt eine Datei, die mit Hilfe des Programms ERUNT eine automatische Registrysicherung durchführt.

lokalen Admin einrichten- erzeugt auf einer Workstation einen lokalen Admin (LMAdmin)

BGInfo einrichten - richtet BGInfo von Sysinternals ein

Systemtools einrichten - richtet eine Systemtools.msc auf dem allgemeinen Desktop ein.

Bei Einstellungen, die einen Geplanten Task erzeugen, gelangt man in das Fenster für die Schedulerplanung (Hinweise siehe dort)

Neustart-Einstellungen setzen - eine newstart.cmd wird in \Toolsverzeichnis\Neustart erzeugt. Diese benutzt die shutdown.exe aus dem Ressource-Kit (wird mit kopiert)

Zeitabgleich-Einstellungen setzen - erzeugt eine settime.cmd unter Toolsverzeichnis\Zeitabgleich. Die Zeitservereinstellungen werden auf die angegebenen gesetzt (standardmäßig PTB-Zeitserver)

Defragmentierung einstellen - erzeugt eine defrag.cmd unter Toolsverzeichnis\Defrag, die einen automatische Defragmentierung der Systempartition durchführt (nur ab W2K3 möglich)

Sicherung der Registry - erzeugt eine regsich.cmd unter Toolsverzeichnis\RegSich, die eine Registrysicherung nach Toolsverzeichnis\RegistrySicherung durchführt. Alle notwendigen Programme werden kopiert.
Es wird das Programm ERUNT verwendet.
Nähere Informationen dazu hier: http://www.larshederer.homepage.t-online.de/erunt/

lokalen Admin einrichten - erzeugt auf einer Workstation einen lokalen Admin (LMAdmin). Auf einem Server ist dieser Punkt deaktiviert

BGInfo einrichten - erzeugt eine bginfo.cmd unter Toolsverzeichnis\BGInfo, die automatisch per Geplantem Task und per Autostart nach Anmeldung die Aktualisierung der Desktopinformationen durchführt. Die dazu notwendigen Programme werden kopiert.
Nähere Infos zum Programm BGInfo gibt es hier: http://technet.microsoft.com/de-de/sysinternals/bb897557(en-us).aspx

Systemtools.msc einrichten - erzeugt eine Datei Systemtools.msc (Microsoft Management Console) auf dem allgemeinen Desktop, die als Vorgabe zur Einrichtung der notwendigen Snap-ins verwendet werden kann.


Explorer-Einstellungen

Diese Einstellungen können über "config" neben den Explorer-Ordner-Einstellungen erreicht werden

Wenn das Häkchen vor der Einstellung entfernt wird, wird die betreffende Einstellung zurückgesetzt.
z.B. Klassische Suche einstellen ohne Häkchen bedeutet, die klassische Suche wird deaktiviert.

Klassiche Suche einstellen stellt die klassische Suche für Dateien ein. (kein "Hunde-Assistent)

Willkommens-Bildschirm nicht anzeigen verhindert, daß nach der Anmeldung der MS-Willkommensgruss angezeigt wird.

Klassiche Systemsteuerung schaltet die klassiche Ansicht der Systemsteuerung ein

Abmelden dem Startmenü hinzufügen fügt dem Startmenü den Eintrag "<Name> abmelden" hinzu

LW-Buchstaben vor Namen anzeigen schaltet die Explorer-Anzeige um auf z.B. "(C:) Lokaler Datenträger"

Desktopbereinigungsassistent entfernen verhindert, daß der Benutzer zum Bereinigen seines Desktops aufgefordert wird.

Netzwerkverbindungen erweitern - die Netzwerkverbindungen können nun direkt über das Startmenü erreicht werden (ausgeklappt)

Klassisches Startmenü - Das Startmenü wird auf die klassiche Ansicht umgestellt (unter Vista/8/10 nicht empfohlen)

Ausführen im Startmenü - "Ausführen" im Startmenü wird freigeschaltet

Desktopsymbole - Auf dem Desktop werden die Standardsymbole angezeigt (Arbeitsplatz, Netzwerkverbindungen etc.)


Systemeinstellungen

Unter Systemeinstellungen kann man grundlegende Einstellungen des Systems konfigurieren
(erreichbar über "config" neben den Systemeinstellungen

Wenn das Häkchen vor der Einstellung entfernt wird, wird die betreffende Einstellung zurückgesetzt (gelöscht).
z.B. "Lanmagic / BRZ-Weblinks auf Desktop erzeugen" ohne Häkchen bedeutet, evtl. vorhandene Links werden gelöscht.

Numlock beim Starten an sorgt dafür, daß die Numlock-Taste nach Start des Betriebssystems eingeschaltet ist.
keine geplanten Updates (nur IE) - schaltet die automatische Updateprüfung des Internet Explorer ab.
Pagefile beim Herunterfahren löschen - löscht die komplette Auslagerungsdatei vor dem Herunterfahren
Achtung! Dieser Vorgang dauert, je nach Größe sehr lange und sollte nur bei erhöhten Sicherheitsansprüchen verwendet werden!
Shutdowntracker abschalten schaltet die seit Windows 2003 vorhandene Frage nach dem Grund des Herunterfahrens ab
Fehlerberichterstattung ausschalten schaltet die MS-Fehlerberichterstattung ab ("nur noch bei kritischen Fehlern...") bleibt eingeschaltet
Dateiausführungsverhinderung ausschalten - diese wird durch einen Eintrag in der BOOT.INI komplett deaktiviert (Die originale boot.ini wird nach boot.xxxxxxx gesichert (xxx stehen für Datum und Uhrzeit)
Unter Vista/8/10 wird diese Einstellung mit bcdedit erzeugt. Eine Sicherung erfolgt in die Datei "Systemlaufwerk:\bootkonfig"
Achtung! Diese Einstellung wirkt erst nach einem Neustart!
Remotedesktop einschalten Der Arbeitsplatzeintrag "Remotedesktopverbindungen zulassen" wird aktiviert, so daß RDP-Verbindungen möglich sind. Der Firewalleintrag wird gesetzt.
Automatischer Neustart nach Bluescreen Wenn ein Bluescreen auftritt startet der Server/PC automatisch nach Abspeichern des Dumps neu
Weblinks auf Desktop erzeugen erzeugt Weblinks auf dem allgemeinen Desktop (www.lanmagic.de , )
Verknüpfung mit Scripts erzeugen erzeugt eine Verknüpfung auf dem allgemeinen Desktop mit dem Ordner Scripts (unter sysvol\domänenname\scripts)
Wenn dieser nicht vorhanden ist (kein Domänencontroller), wird eine Fehlermeldung erzeugt.
 Link zu Aufgabenplanung erzeugen - legt eine Verknüpfung zur "Aufgabenplanung" (geplante Tasks) auf dem allgemeinen Desktop ab
TEMP-Ordner ändern - legt einen Ordner TEMP auf dem Systemlaufwerk an und stellt die Umgebungsvariablen TMP und TEMP (allgemein und aktueller Benutzer) auf diesen Ordner um.
Login-Script anlegen - Legt im Ordner ...sysvol\domänenname\scripts eine login.cmd an, die nach Anpassung als Anmeldescript benutzt werden kann
Wenn eine login.cmd vorhanden ist, wird eine login.example erzeugt.
Verknüpfung zu CMD erzeugen - legt einen Link zur CMD.EXE auf dem allgemeinen Desktop an und erzeugt im Kontextmenü des Windows-Explorers den Eintrag "CMD hier öffnen"
UAC (Benutzerkontensteuerung) abschalten - (nur unter Vista//8/10 verfügbar) schaltet die UAC komplett ab (auf Servern empfohlen)
TCP/IP-Autotuning abschalten - Die TCP/IP-Autotuningfunktion wird abgeschaltet
Link zu Lanmagic-Fernwartung - ein Link zum Download der Lanmagic-Fernwartung (pcVisit) wird erzeugt
Drucker auf Desktop... - Auf dem allgemeinen Desktop und im Explorer wird eine Verknüpfung zum Ordner "Drucker" erzeugt
Buttons "Herunterfahren"... - legt Verknüpfungen zu "Herunterfahren", "Abmelden" und "Neustart" an. (nunter Win8/2012 sehr praktisch)
Charmsbar - deaktiviert unter Windows 8/10 die Charmsbar
Link zu "Ausführen" - erzeugt eine Verknüpfung zu "Ausführen" auf dem allgemeinen Desktop
Firewall abschalten - Die integrierte Firewall wird abgeschaltet (Profil Domäne und Privat)
Alle Systemeinstellungen - eine Verknüpfung zu allen Systemeinstellungen (sog. Godmode) wird auf dem allg. Desktop erzeugt
One Drive deaktivieren - die Verknüpfungen zu OneDrive (Windows 10) werden entfernt

Zusätzlich:
 Der SQL-Securitycheck für Word abgeschaltet, der zu Fehlermeldungen bei Datenbankzugriffen führen kann.
Alle Symbole im Notification Tray anzeigen wird aktiviert


Schedulereinstellungen

Beispiel für die Einstellung eines Geplanten Tasks (Scheduler)

Die Tasks werden unter Systemaccount ausgeführt (empfohlen). Ausnahme bildet BGInfo. Hier sollte ein Administrator-Konto verwendet werden.
Das verwendete Konto wird bei allen Tasks benutzt, braucht also nur einmal eingegeben werden.

Für den Benutzer wird Domänenname\angemeldeter Benutzer (bzw. PC-NAME\Benutzer) vorgegeben.Diese Vorgabe kann angepaßt werden, sollte aber in der Form Domänenname\Benutzer verwendet werden

Benutzername und Passwort werden für ALLE erzeugten Tasks verwendet, brauchen also nur einmal eingegeben werden!

Die Vorgabewerte für Wochentag/Uhrzeit können beliebig angepaßt werden.

Beispiel für einen Geplanten Task mit erweiterten Eigenschaften

Wenn weitere Einstellungen notwendig sind, wird es im rechten Teil des Schedulerplanes angeboten.
Das Beispiel oben bezieht sich auf die Internet-Zeitsynchronisierung. Hier sind die beiden Zeitserver der PTB vorgegeben.

Unter Vista/8/10 werden die Tasks im alten Format erzeugt (*.job-Dateien)


BRZ-Einstellungen

BRZ-Spezifisches
An dieser Stelle können Einstellungen gesetzt werden, die mit BRZ-Programmen (www.brz.de ) zu tun haben

Lanmagic-Logo und Supportinfos kopieren - Im Arbeitsplatz unter "Eigenschaften" wird dann das Lanmagic-Logo angezeigt, sowie Informationen zur telefonischen Erreichbarkeit
PingVPN einrichten - Eine Kommandodatei zum regelmäßigen Anpingen von Netzen wird eingerichtet. Das dient dazu, die VPN-Tunnel zu diesen Netzen aufrecht zu erhalten.
Standardmäßig wird das Netz 62.156.251.0 (BRZ Nürnberg) und 10.100.0.0 (VPN-Softwareclient) angepingt. Weitere können unter "Config" hinzugefügt werden.
Start der BRZ-Datenbank - legt eine Kommandodatei (sqlstart.cmd) unter \BRZ32 zum automatischen Start der BRZ-Datenbank an
Bei geänderten Servicenamen (Standard BRZSERVER) wird dies berücksichtigt
Stop der BRZ-Datenbank - wie Start der BRZ-Datenbank, die Datei heißt hier sqlstop.cmd
Autoreorg der BRZ-DB eine Kommandodatei zum automatíschen Start der Reorganisation wird angelegt (unter Toolsverzeichnis\Autoreorg\doreorg.cmd)
Sie beinhaltet den Stop der Datenbank und den Start der Autoreorg ("brzreorg.exe a")
Die notwendigen Einstellungen für den Autoreorg müssen einmalig gespeichert werden (Über Aufruf der brzreorg.exe - Freischalten und Speichern)
DB-Controller einrichten - installiert den DB-Controller für die BRZ-Datenbank (Ampelsymbol in der Taskleiste) nach Toolsverzeichnis\DBController und richtet ihn standardmäßig ein (automatischer Start, minimiert für alle Benutzer)
Online-Sicherung der BRZ-DB - installiert das Programm brzbakup.exe zum automatischen Onlinebackup der BRZ-DB und richtet es standardmäßig ein (Unter Toolsverzeichnis\DBBackup)


Sonstiges

Sonstige Einstellungen

Ein Klick auf den Namen/Versionshinweis bietet die Möglichkeit, eine E-Mail an den Programmautor zu verschicken.

INI-Datei laden - lädt eine gespeicherte INI-Datei (servinstall.ini). Diese muss sich im gleichen Verzeichnis befinden, wie das Programm.
Alle enthaltenen Einstellungen werden geladen und die entsprechenden Checkboxen initialisiert.
INI-Datei speichern - speichert alle im Moment vorhandenen Einstellungen in einer Datei servinstall.ini (im selben Verzeichnis wie das Programm) ab.
Tasks löschen - öffnet ein Fenster, in dem alle Geplanten Tasks aufgelistet werden, diese können einzeln oder auch als Mehrfachauswahl (mit STRG oder SHIFT) gelöscht werden. (siehe Screenshot)
Unter Vista/8/10 können nur Jobs im alten Format (*.job) gelöscht und angezeigt werden (kein XML-Format)

Alles setzen - setzt alle im Moment gesetzten Einstellungen und erzeugt Geplante Tasks. Eine Logdatei wird erzeugt, die anschließend über "Logdatei ansehen") betrachtet werden kann.
Eine Fehlermeldung wird ausgegeben, wenn unter Schedulereinstellungen für BGInfo kein Name/Passwort angegeben wurden.
Dann kann der Task nicht erzeugt werden.
Evtl. vorhandene Geplante Tasks mit gleichem Namen werden ohne Nachfrage gelöscht und mit den neuen Einstellungen überschrieben. Das wird in der Logdatei dokumentiert.
Updateprüfung - führt eine Prüfung auf vorhandene Updates des Programms im Internet durch. Dazu ist eine Internetverbindung erforderlich (http - Port 80)
Bei Vorhandensein von Updates wird dies angezeigt und es kann heruntergeladen werden.


Logfenster

Alle Informationen im Logfenster werden in einer Datei SERVINSTALL.LOG gespeichert, die im Verzeichnis erzeugt wird, in dem auch die Tools installiert werden.
standardmäßig (System-LW:\LMTools)
Eine evtl. vorhande servinstall.log wird in servinstall.bak umbenannt, um frühere Aktionen verfolgen zu können.


Sonstiges

Lizensierung

Das Programm kann nach dem ersten Start 5 Tage genutzt werden. Danach muß es (kostenpflichtig) lizensiert werden.
Den Lizenzdialog erreicht man im Menü "Über - Lizenz".

Hier tragen Sie Ihren Namen / Firmennamen ein und drucken "Seriennummer generieren".
Die erzeugte Seriennummer mailen Sie mit der Bitte um Freischaltung an itservice@lanmagic.de
Nach Zahlungseingang erhalten Sie dann die Aktivierungsnummer, mit der das Programm freigeschaltet wird.

Beachten Sie, daß bei der Freischaltung exakt derselbe Name benutzt wird.